Overview
When you try to login into your existing Aurea Monitor (Actional / Insight) Management Server (AMS) you are faced (prompted) by the installation configuration wizard usually seen on fresh installation after a restart. It is asking for a license key. You cannot log in to your AMS.
The message is:
"Installation Complete! Please click start to launch the configuration wizard (license key required)".
The user or the administrator has not taken any action (no change was done to the server) and this page was working previously (was able to log in).
Some customers reported this after they had to restart their Management Server after high CPU usage.
Solution
Note: We have reports of this issue for version 10.x (2015) of the product. This is why the instructions below are 10.x specific. If you face this issue on later versions, then instead of ActionalServer.xml you should be looking for AureaMonitorServer.xml.
Root Cause
The mentioned message generally is displayed for a new setup or if the configuration got corrupted for an existing setup.
Diagnosis
Check the size of ActionalServer.xml (in your <installDir>\config folder). If it is few KBs then the configuration is likely corrupted.
If you have a backup of this file (it is a recommended best practice to have a backup of this file, as per the Installation Guide) you should observe the size difference between your current config file ActionalServer.xml and your backup (eg: ActionalServer.xml.old)
Resolution
The solution is to overwrite your current corrupted config with the one from your backup and restart the server.
- Before stoping the server verify that you have a backup config and that backup config is not corrupted.
- The source of your backup config can be several:
- your ..\config folder should contain an ActionalServer.xml.old file created by the server after your last restart. Take a copy of this file before you restart the server, otherwise, the old file becomes corrupted, too. If the server was already restarted, the .old file got overwritten and corrupted, too.
- you might have created previously a manual backup of you ActionalServer.xml and placed on a different location (a backup storage)
- if you have several nodes, you could get a config file from a different node that has not been corrupted yet
- a config file from a similar AMS version that you have in your environment. Eg. a config file of 10.0.1.23 (HF23) could work for 10.0.1.15 (HF15) because the server will automatically upgrade the config file on restart
- Stop the Actional Server, before overwriting the configuration file.
- Overwrite your current ActionalServer.xml with the one from your backup (eg: if your ActionalServer.xml.old is not corrupted you just rename it to ActionalServer.xml)
- Start the Server.
- Verify that you are able to log in.
- If you are still not able to log in, you will need to create a new (fresh) configuration.